Android Studio Project is using an old version of the Android Gradle plug-in Error



Android Studio 0.4.0으로 업데이트 되면서 이전에 만들었던 프로젝트를 불러 오려면 다음과 같은 오류가 발생한다. 

Project is using an old version of the Android Gradle plug-in.

The minimum supported version is 0.7.0.

Please update the version of the dependency ‘com.android.tools.build:gradle’ in your build.gradle files.


 

해결책:

Gradle Plugin 0.7.0과  gradle-wrapper 1.9로 사용하도록 변경하면된다.


build.gradle 파일

buildscript {

    repositories {

        mavenCentral()

    }

    dependencies {

        classpath 'com.android.tools.build:gradle:0.7.+'

    }

}

gradle-wrapper.properties 파일

distributionUrl=http://services.gradle.org/distributions/gradle-1.9-all.zip

하위 호환성이 뭐이래 생각하지만, 아직 베타니까;;